まつまるまつまる

どうも、まつまるです。このエラー対処に3時間かかりました。

はい、結論から言います。

ターミナルで以下コマンドを叩く。
$ flutter downgrade

 

以上です。僕の場合はこれで直りました。

よくよく考えてみると、flutter upgradeをしてからこのエラーが出てきたので、ダウングレードしてやればOKでした。

それでもエラーが消えなければ以下の記事を参考にしてみてください。

https://zenn.dev/xxminamixx/articles/ba63bd9ce69aaef5f71b

https://qiita.com/OkamotoHaru/items/0ef3f0097960e4a39898

https://github.com/flutter/flutter/issues/23465